Problem J: 排序降序(请使用sort函数完成此题)
Memory Limit:128 MB
Time Limit:1.000 S
Judge Style:Text Compare
Creator:
Submit:9
Solved:9
Description
输入n个数,然后从大到小输出
Input
第一行输入一个整数n(0<n<=100000),表示有n个待排序数据;
第二行输入n个整数
第二行输入n个整数
Output
降序输出排序结果
Sample Input Copy
5
3 2 1 4 5
Sample Output Copy
5 4 3 2 1
HINT
需要从大到小进行排序时,我们可以用 sort(arr+n,arr+m,comp)进行排序。
不过,在调用sort(arr+n,arr+m,comp) 之前我们需要自己写个 comp函数。
从大到小排序的comp函数可以这样写:
int
my_comp(int a,int b)
{
return
a>b; //在两元素相同时一定要返回 0 或者 false
} //comp函数的名字是由我们自己决定的,例如可以叫 //cat_cat,dog_dog 等等
//程序实现从键盘读入10个数,然后从大到小输出的功能
#include<bits/stdc++.h>
using namespace std;
int a[10];
int my_comp(int a,int b)
{
return a>b; //如果a>b 则返回1 ,否则返回 0
}
int main()
{
for (int i=0;i<10;i++)
cin>>a[i];
sort(a+0,a+10,my_comp);
for (int i=0;i<10;i++)
cout<<a[i]<<' ';
return 0;
}