Problem I: 排序升序(请使用sort函数完成此题)

Memory Limit:128 MB Time Limit:1.000 S
Judge Style:Text Compare Creator:
Submit:15 Solved:11

Description

输入n个数,然后从小到大输出

Input

第一行输入一个整数n(0<n<=100000),表示有n个待排序数据;
第二行输入n个整数

Output

升序输出排序结果

Sample Input Copy

5
5 4 3 2 1

Sample Output Copy

1 2 3 4 5

HINT

自带排序算法的一般形式为:

sort(arr+m,arr+n);    //将数组arr的下标为m的元素到下标为n-1的元素进行从小到大排序

对于sort(arr+m,arr+n) 我们举个简单的例子:

//这个程序实现从键盘读入10个数,然后从小到大输出的功能

#include<bits/stdc++.h>

using namespace std;

int a[10];

int main()

{

  for (int i=0;i<10;i++) 

     cin>>a[i];

  sort(a+0,a+10);

  for (int i=0;i<10;i++) 

     cout<<a[i]<<' ';

  return 0;

}

Source/Category